Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GIGABYTE Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 18. Dezember 2009, 21:10

GA-790FX-TA-UD5 Win7 Installation auf RAID5 bricht beim Neustart ab "Computer konnte nicht auf den Start der nächsten Installationsphase vorbereitet werden"

Hallo Zusammen!

Ich habe diese Woche einen neuen PC zusammengestellt:
GA-790FX-TA UD5P
PhenomII X4 965 BE C3-Stepping
4GB TeamXtreem 1833 CL8 LowVoltage Kit
4xSeagate SATA2 7200.12 1000GB
NV QuadroFX 540 (Von der Uni ausgeliehen, solange die 5870 so schlecht verfügbar und teuer ist - zum Arbeiten taugt sie allemal)
Cougar 550W Netzteil
Altes IDE DVD-Laufwerk
Win7 Pro 64bit OEM

Alles zusammengebaut, die Festplatten an SATAII 0-3 (SB750) angeschlossen. Im BIOS (OnChip SATA Type) die RAID-Funktionalität aktiviert. Gespeichert. Neustart.
Mit Strg-F den RAID-Konfigurator aufgerufen. Dort waren alle Platten richtig erkannt. RAID5 ausgewählt - Alle 4 Platten hinzugefügt, sonst nichts geändert. Meldung: Gesamtkapazität des Arrays 3GB. Bestätigt. Neustart.
Win 7 DVD ins Laufwerk. Die Windows-Installation beginnt. Das RAID5 Array wird bei der Wahl des Installationslaufwerks zunächst nicht erkannt. Also die aktuellen RAID-Treiber für Win7 64bit von der Gigabyte-Seite geladen. (AMD SATA RAID driver Version 3.1.1540.127 vom 01.12.2009. Auf USB-Stick entpackt. In der Win7-Installation auf dem Stick den Treiber \SB7xxW7\RAID\x64\ahcix64s.inf ausgewählt. Daraufhin wurde das RAID-Array korrekt erkannt. Installation fortgesetzt. Es läuft alles automatisch bis der Neustart ansteht: Hier kommt dann die o.g. Meldung, dass der PC nicht auf die nächste Installationsphase vorbereitet werden konnte. Nach OK wird alles zurückgesetzt und die Win7-Installation befindet sich wieder bei der Sprachauswahl. :thumbdown:

Im Internet habe ich zu diesem Problem nichts vergleichbares gefunden. Da ich mit RAID-Arrays bisher keine praktische Erfahrung habe, wollte ich hier um Rat fragen.

Zum Vergleich habe ich im BIOS den OnChip SATA Type auf IDE zurückgesetzt. Hier wurden die HDDs von der Win7 Installation ohne zusätzlichen Treiber korrekt erkannt und die Installation lief problemlos durch. Im Windows waren die vier Platten ansprech- und formatierbar. Es ist also offensichtlich ein Problem mit der RAID-Funktionalität. RAID5 auf der SB750 war für mich der Hauptgrund für ein AMD-System. Hat jemand ähnliche Erfahrungen gemacht und eine Lösung gefunden?
Planloses Ausprobieren wollte ich vorerst vermeiden, weil die Installation bis zum Abbruch gut 30 Minuten dauert. Das "expandieren" zieht sich recht. Ist das eigentlich normal?

Wäre für Hilfe dankbar.
-Robert

Oberst

Erleuchteter

Beiträge: 5 370

Wohnort: südlich des Weisswurstäquators

  • Nachricht senden

2

Samstag, 19. Dezember 2009, 01:19

Hallo,
vermutlich spinnt der Treiber. Daher vielleicht mal von hierden aktuellen Cat. 9.12 Treiber probieren. du findest ihn so:
Motherboard/Integrated Video Drivers ->
Individual Drivers (Motherboard/Chipset) ->
Windows 7 64-bit ->
RAID Driver.
Die .exe laden und entpacken lassen (geht auf jedem Rechner mit Windows). Das Setup dann abbrechen. Die Treiberdateien findest du dann unter:
C:\ATI\Support\9-12_win7_32-64_raid\Packages\Drivers\SBDrv\SB7xx\RAID\W764A.
Dau kannst auch das komplette "C:\ATI\Support\9-12_win7_32-64_raid" Verzeichnis auf den Stick kopieren.

Was auch noch denkbar wäre: Ram Probleme. Vielleicht spinnt beim kopieren der Ram und beim IDE Setup hattest du nur Glück, dass es mal lief. Daher vielleicht auch mal mit Memtest86+ (gibt's als BootCD zm Download) den Ram testen (einige Durchläufe), wenn der andere Treiber nicht hilft.
Gruß Oberst.

3

Samstag, 19. Dezember 2009, 12:18

Serwus (Wie es südlich der Donau heisst :beer: ).

Zuerst Danke für die schnelle Antwort!Ich habe den aktuellen Treiber (Stand 17.12.2009) von AMD gezogen und verwendet. Hat leider nix gebracht. Die Installation ist gelaufen bis zum Neustart, wo leider wieder die gleiche Fehlermeldung kam. Dummerweise schweigt sich Win7 zur genauen Fehlerursache aus...
Memtest86 habe ich noch nicht ausprobiert, den Memtest von der Win7-DVD habe ich 5x durchlaufen lassen, ohne Beanstandung. Den RAM entlastet weiterhin die Tatsache, dass ich Win7 2x reproduzierbar im IDE-Mode erfolgreich installieren konnte und bisher 3x im RAID-5-Mode nicht, unabhängig vom Treiber (2xGigabyte/1xAMD-Treiber)
Momentan läuft der Intensivtest von Seatools, um die Funktion der Festplatten sicherzustellen. Wird bei 4x 1000GB noch bis abends dauern. Dies erst mal als Zwischenstand.
Woran könnte es noch liegen? Als 64-bit OS sollte Win7 keine Probleme mit 3000GB-Partitionen haben, oder?♦

Gruß Robert (Preuße mit mildernden Umständen: Lebkuchenpreiß, Mittelfranken)

4

Samstag, 19. Dezember 2009, 14:04

Hallo Robert,

unterstützt Win7 überhaupt ein RAID5 als 'Systemlaufwerk'? Ich denke, diese Konfiguration wird nicht so üblich sein, da im "worst case" bei einem fehlerhaften RAID das System nicht mehr in der Original-Konfiguration gestartet werden kann und somit auch der Zugriff auf die Daten sehr kompliziert wird.
Wie wäre es denn mit einem zusätzlichen RAID0 (mit 2 kleineren Laufwerken) als reines 'Systemlaufwerk'? Das könnte viel Ärger ersparen, angefangen bei der Installation bis hin zu einem Festplattenfehler.

André

5

Samstag, 19. Dezember 2009, 14:49

Hallo Andre,

Meine Infos stammen primär von Wikipedia und THG (als die Seite noch gut war) - und so wie ich es verstanden habe, ist es Win zunächst nahezu egal wo es sich draufpackt, solange das jeweilige Gerät bootfähig ist. Ob USB-Laufwerk, virtuelles Laufwerk/System, LAN oder RAID usw. . Sobald es mit dem entsprechenden Controller sprechen kann (ggf. mittels gesondert zu lieferndem (Slipstream,Floppy,USB) Treiber) sieht es nur ein homogenes, großes Laufwerk. Was im Hintergrund passiert, woraus sich das Laufwerk zusammensetzt (Flash-Chips, Festplatten, RAM-Module usw. an USB,LAN,SATA,IDE,PCIe...) , ist Win zunächst egal, weil das der jeweilige Controller übernimmt.
Entsprechend gehe ich davon aus, dass es kein Problem sein sollte Win auf ein RAID 5 oder ein anderes RAID-Level zu installieren. Und auch bei einem beschädigtem RAID5 (Ausfall einer Platte) sollte ein sicheres hochfahren noch gewährleistet ist, weil der Controller den Feher erkennt und auf die nötigen Informationen aus den redundanten Daten rekonstruiert, was das System zwar verlangsamt, aber nicht ausfallen lässt. Windows hat damit erst mal nichts zu tun.

Absolut entscheidend ist natürlich ein problemloses Funktionieren des entsprechenden Treibers...

Soweit ich weiß, stellt die SB750 ja ein Hardware-Raid zur Verfügung. Anders wäre es mit einem Software-Raid, das erst im der Treiberschicht eines laufenden Windows ein RAID emuliert.

Vielleicht kann der Herr Oberst hier noch etwas mehr Licht ins Dunkel bringen...

Grundsätzlich hast du aber recht, ich denke schon darüber nach, 1 oder 2 SSDs an den SATA3-Controller zu hängen und OS und Anwendungen dort zu installieren. Für die nächsten 1-2 Jahre möchte ich aber die Geschwindigkeits- und Sicherheitsvorteile eines RAID5 mit ausgereiften Festplatten nutzen und der SSD-Technologie noch zusätzliche Entwicklungszeit gönnen.

Gruß
Robert

6

Samstag, 19. Dezember 2009, 15:56

Gerade habe ich noch das hier entdeckt ... Es liegt demnach wohl doch an den 3TByte, in Zusammenhang mit der Systempartition.

7

Samstag, 19. Dezember 2009, 19:04

Nächster Zwischenstand:

Danke Andre, du hast mich auf die richtige Spur gebracht:

Zuerst habe ich ein RAID10 mit 2000GB eingerichtet. Darauf ließ sich Win problemlos mit den AMD-Treibern installieren. JEtzt will ich noch das dritte TB klarmachen, also RAID5:

Zwei RAID5 Arrays, eins mit 2000GB, eines mit 1000GB eingerichtet. Win habe ich auf das kleinere installiert - keine Probs bei der Installation, aber das 2000GB-Array wird am Arbeitsplatz nicht angezeigt. Vielleicht ist es ein paar MB zu groß?
Nächster Versuch: Zwei RAID5 Arrays, beide 1500GB. Installation von Win problemlos - aber nur das Array mit Win wird im Arbeitsplatz erkannt. *grummel. Gerade lade ich die komplette Catalyst 9.12 Driver Suite und werde diese mal installieren. Mal schaun was passiert.

Im Gerätemanager sind jedenfalls alle 4 Platten angezeigt.

Nur irgendwie bin ich schon geschockt dass die Microseftl nicht in der Lage sind Laufwerke >2TB ohne Mucken anzusteuern. Dieses Jahr kamen 2TB-Festplatten raus, nächstes Jahr könnten wir vielleicht schon 6TB-Exemplare sehen... Mit meiner ersten XP-Installation vor fast 10 Jahren hatte ich weniger Probleme...

8

Samstag, 19. Dezember 2009, 20:46

Der Arbeitsplatz zeigt ja nur eingerichtete Laufwerke an, keine "rohen" Arrays - musst du hier nicht erst in der Datenträgerverwaltung (so es die in Win7 noch gibt) eine Partition anlegen und einen Laufwerksbuchstaben zuweisen? Auf dem "Systemarray" geschieht dies ja automatisch während der Installation, der Rest kann doch Windows erst mal egal sein...

9

Samstag, 19. Dezember 2009, 22:25

Haha!! Juhuu!!! :thumbsup: :thumbsup: :thumbsup: Jetzt hab ichs kapiert. Alles funktioniert wie gewünscht.

Die Wichtigkeit der Datenträgerverwaltung war mit nicht ausreichend bewusst.
Seit DOS und Win3.11 (Mein erster PC - Anno1994: 486DX 40MHz, 4MB(!)RAM, 340MB(!)HDD *schwelg - nach Aufrüstung auf 8MB RAM sind Leute Schlange gestanden, um DOOM I ruckelfrei zu spielen) war eine Platte im Arbeitsplatz und die hat man formatiert. Und sonst war da nichts.
Mit dieser neuen Ebene der Datenträgerverwaltung konnte ich schon bei XP nichts anfangen. Dass sie hier entscheidend ist und funktioniert, hab ich jetzt gelernt.

Also zusammengefasst:
Windows ist auf ein Array und/oder Partition < 2TB zu installieren.
Der verbleibende HDD-Platz muss im danach laufenden Windows in der Datenträgerverwaltung initialisiert und ggf. partitioniert werden. Für Windows-Laufwerke >2TB ist das GPL-Dateisystem zu bevorzugen.

Windows7 ist jetzt auf einem gemütlichen 100 GB-Array
Das 2,7 TB Datengrab ist als GPL initalisert und läuft.

Also nochmal vielen Dank, Andre und Oberst.
Gruß Robert

10

Samstag, 19. Dezember 2009, 22:58

Prima! Zeigt sich wieder mal das alte Phänomen: Kaum macht man es richtig - schon funktioniert's ^^
Das mit der 2-Terabyte-Grenze von Windows wusste ich vorher auch nicht, in diesen "Regionen" habe ich noch nichts gebaut. Allerdings würde ich auf einem PC auch niemals so große Laufwerke anlegen, eher auf einem Server - und der würde ohnehin unter Linux laufen.
Trotzdem scheint mir deine Lösung noch etwas riskant: Du schreibst oben, dass der Gerätemanager alle vier Platten anzeigt - bei einem "echten" Hardware-RAID dürfte er die doch gar nicht sehen!? Hier scheint also noch einige Software-Unterstützung durch den Treiber dahinter zu stecken; hoffen wir, dass dir niemals eine Platte ausfällt...

11

Samstag, 19. Dezember 2009, 23:55

Zitat

Kaum macht man es richtig - schon funktioniert's ^^
Allerdings.
Die 3TB-Liga ist für mich auch neu. Im Laptop hatte ich 2x120 GB und in dem Rechner von 2002 nach diverser Aufrüstung 320GB (Ursprünglich 40GB). Aber als exotisch oder Server-Revier kann man 2TB kaum mehr bezeichnen. Wir haben Mitte des Jahres 2TB-Laufwerke auf den Consumer-Markt bekommen. Ich könnte mir gut vorstellen nächstes Jahr 4- oder sogar erste 6 TB -Festplatten zu sehen. Die vier 1TB-Platten gabs für etwa 60 Euro das Stück. Und was Windows angeht: Ein Feund an der Uni hat seit Ende Juli eine Win7-Server-Version ununterbrochen problemlos laufen. Der er Kernel scheint durchaus ein Fortschritt zu sein.

Ob Windows die vier Platten durch den Controller durch sieht, kann ich nicht einschätzen, aber es ist mir erst mal ganz recht - so kann ich Temperaturen und SMART-Infos auslesen. Vielleicht bekommt Win die Infos vom BIOS.
Zur Frage ob RAID 5 in meiner Ausführung sicher ist, wird morgen die Probe aufs Exempel gemacht. Ich kopiere gerade meine externe Platte (400GB) auf das große Array. Werde morgen dann eine der RAID-Platten abziehen und am anderen Rechner formatieren. Dann wieder anstecken. Das Array sollte nach Fehlermeldung korrekt rekonstruiert werden... Mal schaun wie lang das dauert. Und die Daten liegen ja noch auf der externen Platte...

Eine Frage gibt es noch: Was ist eigentlich wenn mir das Mainboard mit dem Controller drauf verreckt? Kann ich die Platten mit dem Array drauf dann an einen beliebigen anderen RAID5-Controller stecken, oder hab ich dann ein fettes Problem?? Hierzu habe ich widersprüchliche Aussagen gefunden. (auch @ Admin:) Ist Gigabyte hierzu aussagefähig?

Wahrscheinlich gilt weiter die alte Regel, das man nie genug Sicherungskopieen haben kann...

Dann eine gute Nacht allesamt. :sleeping:
Robert

Oberst

Erleuchteter

Beiträge: 5 370

Wohnort: südlich des Weisswurstäquators

  • Nachricht senden

12

Sonntag, 20. Dezember 2009, 02:03

Hallo,
zunächst mal:
Onboard Raidcontroller sind eigentlich immer ein Software-Raid oder eher Firmware-Raid. Sogar auf Server-Platinen gibt's in der Regel keinen Hardware-Raid.

Falls das Board defekt geht, kannst du das Array an einem Board mit SB750 wieder in Betrieb nehmen. Vielleicht geht es auch an anderen Boards mit Raid5-Support. Aber das ist eher Glücksache, darauf würde ich nicht wetten.

Das Problem mit Win7 und der maximalen Array-Größe ist allerdings etwas komisch. Eigentlich sollte man meinen, dass MS das beim Setup automatisch abfängt.
Gruß Oberst.

13

Sonntag, 20. Dezember 2009, 03:32

Wird wohl daran liegen, dass Microsoft selbst unter Win7 noch MBR bevorzugt.
Warum die nicht auf bei den Größen GPT umsteigen ist mir schleierhaft ;)
Solltest du unbedingt ein 3TB Array wollen, versuch doch mal das Array mit einem Livesystem, oder mit einem auf einer anderen Platte liegenden Vista/Seven, in ein GPT System zu ändern.
Mir wäre das allerdings zu viel Arbeit und ich würde den letzten Teil einfach als Raid10 oder 0 einrichten.
Habe das bei mir ähnlich eingerichtet und gerade bei Videobearbeitung und beim Entpacken großer Archive ist die Schreibgeschwindigkeit eines Raid 0 schonmal praktisch, wenn alles wichtige woanders liegt ;)
Beim Lesen ist ein Raid 5 ja kaum langsamer...
Meinungsfreiheit heißt nicht, dass ich mir jeden Scheiß anhören muss.
Falls jemand Kritik an mir oder meinen Beiträgen äußern möchte:
Draußen gibt's ne Wand, die sich das gerne anhört

14

Sonntag, 20. Dezember 2009, 17:51

Ich nochmal.

Heute vormittag habe ich wie angekündigt eine Platte des Arrays mit SeaToolsDOS formatiert, also die Daten darauf zerstört. Nach Neustart ließ sich Windows interessanterweise nicht starten."Betriebssystem fehlt". Ich habe dann das SATA-Kabel von der formatierten Platte abgezogen und Win ist gestartet. Sogar vergleichsweise flott. Dann RaidXpert aufgespielt. Die Weboberfläche ist etwas gewöhnungsbedürftig, aber OK. (pass und login: admin). Die formatierte Platte angesteckt. hotplug. In RaidXpert waren beide Arrays als kritisch eingestuft. Dann rebuild aufgerufen. Hat für insgesamt etwa 3GB 5Std gedauert. Aber erfolgreich. RaidXpert bietet auch eine Scandisk-Funktionalität. Wünschen würde ich mir noch die genauen SMART-Attribute und die Temperatur der Platten.

Was mir etwas Bauchschmerzen bereitet, ist die Beobachtung dass Win mit einer leeren Platte nicht starten wollte und erst nach abstecken dieser Platte gestartet ist. Und dass zum Rebuild ein laufendes Windows erforderlich war. In der BIOS-Oberfläche gibts nur die Meldung dass das Array kritisch ist.
Ich werde mir wohl sicherheitshalber einen Win-Boot-Stick basteln. Da gabs vor ein paar Monaten eine Anleitung auf THG.
Das Betriebssystem auf eine einzelne gesonderte Platte zu spielen find ich auch nicht so sinnvoll, weil im Schadensfall dann auch der Posteingang, das Download-Verzeichnis usw. woran man immer nicht denkt, weg sind... vielleicht zwei flotte SSDs in RAID1...

Interessant fand ich auch [url]http://blogs.zdnet.com/storage/?p=162[/url] - keine Ahnung wie das einzuschätzen ist, aber man kommt offensichtlich um die weitere Sicherung für die Urlaubsfotos und die in jahrelanger, liebevoller Kleinarbeit erarbeitete XXX-Sammlung nicht herum.

Grüße Robert

15

Sonntag, 20. Dezember 2009, 22:04

Ich kenne zwar deinen Raidcontroller nicht,
aber bei Intel musst du erst vor dem Booten im Menü sagen, dass er das Raid reparieren soll.
Dann stellt er von Fehler auf Rebuild um.
Ich vermute mal, dass es im Menü deines Controllers eine ähnliche Funktion gibt...
Meinungsfreiheit heißt nicht, dass ich mir jeden Scheiß anhören muss.
Falls jemand Kritik an mir oder meinen Beiträgen äußern möchte:
Draußen gibt's ne Wand, die sich das gerne anhört

Oberst

Erleuchteter

Beiträge: 5 370

Wohnort: südlich des Weisswurstäquators

  • Nachricht senden

16

Sonntag, 20. Dezember 2009, 23:19

Hallo,
vermutlich hat das BIOS die einzelne Platte als primäre Platten eingestellt. Da war ja nix drauf, daher Fehlermeldung...
Gruß Oberst.

17

Montag, 21. Dezember 2009, 10:56

Was mir etwas Bauchschmerzen bereitet, ist die Beobachtung dass Win mit einer leeren Platte nicht starten wollte und erst nach abstecken dieser Platte gestartet ist.
Ich kann mir vorstellen, dass eine "leere" Platte nicht als "ausgefallen" erkannt wird - letztlich kann der Controller ja Daten von der Platte lesen. Ob diese nun gültig sind oder nicht, wird er nicht entscheiden, da beim Lesen allgemein keine Prüfung gegen die Paritätsdaten geschieht; das BIOS wird also einen fehlerhaften MBR auf dem Array vorfinden und richtigerweise Windows nicht starten können. Erst, wenn von einer Platte tatsächlich keine Daten mehr kommen, wird der "Notmechanismus" greifen und die fehlenden Daten werden (vorerst dynamisch) mit Hilfe der Paritätsdaten rekonstruiert.
Und dass zum Rebuild ein laufendes Windows erforderlich war.
Hier wird die Sache mit dem "Fake-RAID" relevant: Für einen "Notstart" wird die Leistung des Controllers ausreichen - hier müssen nur die fehlenden Daten (über ein paar einfache logische Verknüpfungen) einmalig wiederhergestellt und "weitergereicht" werden. Zum richtigen Betrieb und zur Wiederherstellung des Array müssen allerdings definierte Schreibzugriffe auf die Festplatte erfolgen - dies wird der Controller allein nicht schaffen und daher muss die entsprechende Software ran.

Immerhin geht die Hardware-Unterstützung so weit, dass es für einen Notstart reicht - dies hätte ich nicht mal vermutet. Würdest du allerdings im Ernstfall erkennen, welche Platte fehlerhafte Daten liefert (dies ist ja wahrscheinlicher als ein sofortiger Totalausfall)?

Social Bookmarks